Symptom:

A user authenticates with an AD account to the KIOSK and scans a file >

The file is uploaded to the SFT >

The user receives an E-mail from SFT with the download link >

After authenticating to the SFT with the same credentials, the following error message appears:

Not Autorized

The access to the current file was not granted you.



Cause:

The user's E-mail account belongs to two SFT users (usually it will be the user itself and the local SFT administrator).


When two users with the same E-mail address are configured in SFT, the KIOSK will show a random number in the message appears after the file has been uploaded to SFT.

This means that the KIOSK did not find a matching account/E-mail address in the SFT for the current logged-on user, so the files are being uploaded to an SFT guest account.

  

If the KIOSK found a matching SFT account, the message should look like this (without a random number):



 

 

 

 

Solution:

If the additional E-mail account belongs to the local SFT administrator: 

  • Perform a clean uninstall as described in here
  • Install the SFT again
  • in the "Welcome" wizard, define a different E-mail address that does not belong to any user.
  • Re-configure all the necessary settings (license, AD, SMTP…)

If the additional E-mail account belongs to another AD account:

  • Make sure each AD user has a unique E-mail address.