CPM installations shows .NET errors on platform upload

Modified on Mon, 11 Mar, 2019 at 10:55 AM

Symptom:

When trying to install CPM v10.7 and above, which now uses REST to upload platforms to the vault, you get a failed message for the upload and the logs show .NET errors


Cause:

This is caused by the fact that the CPM, by default, only supports TLS 1.0 connections which are now deprecated. Organizations that have TLS 1.0 disabled by a GPO will cause the failure above.


Solution:
In order to solve the issue, you need to update the registry of the CPM and enable support for TLS 1.1 and TLS 1.2:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319]
Create a DWORD "SchUseStrongCrypto"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\v4.0.30319]
Create a DWORD "SchUseStrongCrypto"=dword:00000001


After adding the keys above, restart the server and run a repair on the CPM installation to complete it.

More info can found in solution #00005074 in the CyberArk portal.


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