Symptom:
Metadefender Mail Agent is listening on port 10025 by default
Metadefender Mail Agent is listening on port 10025 by default
Cause:
This is the Defualt port Mail Agent is configured to use, however this can be changed.
To change the Default port of Mail Agent:
- Navigate to Opswat install directory (default: "C:\Program Files (x86)\OPSWAT\Metadefender Core 8"), Then navigate to folder "Metadefender Mail Agent"
- Open "Metadefender.Email.Engine.Generic.Agent.dll.config" with notepad or any other editor.
- Replace the value of port under the line "<setting name="EmailRelayInPort" serializeAs="String">".
- Save the file.
- Restart the Metadefender Mail Agent Service.
- Check to see the server is listening on the desired port. In CMD run the following command: "netstat -na | findstr "port_number"" (the port number could also be seen on metadefender core management console, in Sources -> Mail Agent -> Setup.
* Note: If the port hasn't changed after the services restart, then a repair to the installation is required.
- Run the metadefender core setup again and choose repair.
- Restart the Server.
- Check to see the server is listening on the desired port. In CMD run the following command: "netstat -na | findstr "port_number"" (the port number could also be seen on metadefender core management console, in Sources -> Mail Agent -> Setup.