Symptom:
When trying to release any quarantined emails from the "quarantine" section at the web management, nothing happening and you are getting "Failed to release" alert.
Cause:
The quarantine service uses its own SMTP configuration to send reports and send the released emails, he is not using the SMTP configuration releated to the Mail Agent.
Solution:
To configure the SMTP configuration to the quarantine service that will give you the ability to release emails, you will need to open the web management console> Quarantine>Configure Quarantine Reports.
Under "SMTP Configuration Settings" section press "Update" and add your internal SMTP configuration and then press "SAVE".
Now try again to release an email from the quarantine.